View Full Version : PROBLEM: Backup copy won't boot computer

05-12-2005, 05:47 PM
Copied startup disk (not current startup disk) containing OS X and OS 9.

OS X and OS 9 on the backup copy appear in System Preferences:Startup Disk, but they will not startup the computer.

SuperDuper 1.5.5 (v74)
OS X 10.3.9
Swiper boyz (http://twitter.com/SwiperboyzBabiM)

05-12-2005, 05:55 PM
OK, Steve. Please make sure the drive is attached, and send a System Profiler report to support. (Generate it by running System Profiler, and choosing File | Save. Save to XML, then email in with the info above.)

05-12-2005, 06:05 PM
Can you be more specific about info you are looking for?

I would like to help, but don't want to send complete profile.
Buy extreme q vaporizer (http://vaporizers.net/extreme-vaporizer)

05-12-2005, 06:17 PM
Might I ask why? There's nothing especially troublesome in there.

05-12-2005, 06:20 PM
I don't wish to share the information, that's all.
BUY SILVERSURFER VAPORIZER (http://vaporizers.net/silver-surfer-vaporizer)

05-12-2005, 06:31 PM
Well, it's difficult for me to diagnose this without most of the information in the report.

At the very least, I need a full list of your FireWire, USB and ATA devices -- in fact, all the hardware parts are pretty much required.

I'd also need a list of all extensions and installed software.

Finally, your System and Console logs.

If you wish to bundle those up outside a report and send that in, that'll be fine. But, without that, it's very hard for me to determine the potential causes for this kind of problem.

05-12-2005, 06:40 PM
Do you have any insight into why a backup copy might not boot?

Really, I was hoping for some suggestions or known problems that might solve the problem or be ruled out.
Buy Silversurfer Vaporizer (http://vaporizer.org/reviews/silver-surfer)

05-12-2005, 06:42 PM
Yes. It's possible you have an incompatible enclosure, or software that runs at startup that's having trouble running on a different volume than the original.

Have you tried installing a basic OSX installation on this drive, and booting from it?

05-12-2005, 06:55 PM
Yes. It's possible you have an incompatible enclosure, or software that runs at startup that's having trouble running on a different volume than the original.

Have you tried installing a basic OSX installation on this drive, and booting from it?

Well, I had hoped making a backup copy would have been sufficient, so this would not be necessary (as SuperDuper is advertised)... :mad:

But, your questions/suggestions are helpful... the backup copy is on an ATA card. The ATA card supports startup, though. But, the drive is 250GB, and that may not be supported to startup on my Mac (G4 Quicksilver), because it has a 128GB drive limit on its built-in ATA bus and (afaik) firmware. (The ATA card and its driver extension overcome the limit, but perhaps they must be loaded first.)

I can move the drive to firewire and see if that helps. But, assuming no other problems, it looks like I'm dealing with hardware limitations of my Mac, not a problem with SuperDuper here.
YAMAHA G-245S (http://www.yamaha-tech.com/wiki/Yamaha_G-245S)

05-12-2005, 07:04 PM
Well, we can only do so much here, Steve, given the variations in hardware and software present on the Macintosh. I don't think we deserve your anger, however.

Anyway, please do let me know what you discover with your particular setup. If this is something we should add to a FAQ, I'm happy to do so -- or, at least, get the information documented here in the thread so others in a similar situation can benefit from it.

05-12-2005, 07:08 PM
Well, we can only do so much here, Steve, given the variations in hardware and software present on the Macintosh. I don't think we deserve your anger, however.

I'm with you, the anger is directed at the situation only... :eek:

I thought I made it clear the problem seemed not to be SuperDuper here!

Thanks for the help to troubleshoot this! :)
CHEVROLET S-10 SPECIFICATIONS (http://www.chevy-wiki.com/wiki/Chevrolet_S-10)

05-12-2005, 07:13 PM
No problem... good luck running it down.

If you test against FireWire, make sure your FireWire drive is boot-supported too. Some aren't -- most recent LaCie, OWC and WiebeTech are (though always make sure you have the most recent firmware)...

05-12-2005, 08:09 PM
The backup copy starts up on firewire in OS X with no problems... but doesn't startup in OS 9.

This is probably also a hardware limitation, with OS 9 and my Mac.

here's apple technote relating to hard drives- it's hard to find unless you know it exists. the other info about startup and workarounds is scattered in different places (such as peripheral vendor support pages, etc.)

Michigan Medical Marijuana Dispensaries (http://michigan.dispensaries.org/)

05-12-2005, 08:15 PM
Amazing that it wasn't that long ago, Steve. The MDD G4's were the last of that line. Wow...

Anyway, thanks. Glad it came up OK on FireWire!

05-13-2005, 04:28 AM
more info:

OS X: after starting up the backup copy (250GB) on firewire, I moved it back to the ATA card, and it now starts up correctly there, as well!

OS 9: the backup copy still will not boot in OS 9 on firewire or the ATA card. DiskWarrior 3.0.3 reports that there is no blessed System Folder. Although DiskWarrior prompts to assign blessed folder, it does not solve the problem. However, when the disk is mounted in 9, the System Folder displays the icon indicating that it is blessed. There may be a problem with DiskWarrior here, also.

Note: When the backup copy is copied to another disk (120GB, not 250GB), the new copy behaves normally and boots in OS X or OS 9 with no problems. (The new copy was made after the backup copy was booted on firewire, however.)

These issues may still be somewhat hardware-specific due to using a large drive, but the OS X anomalies seem to indicate there are other problems that may still be SuperDuper-related, as far as having a good copy which is capable of booting up normally in OS X.
Amc Rebel History (http://www.dodge-wiki.com/wiki/AMC_Rebel)

05-13-2005, 11:05 AM
We're not aware of any problems in this area. It's possible that your kernel extension cache -- once built -- was retained on your second copy, and this allowed the system to boot due to some weird peculiarity of your particular configuration, but you didn't indicate how you moved it, so it's hard for me to say.

If you moved it and retained the kextcache, try creating a copy script that doesn't ignore this file. This is something that shouldn't be retained, especially when a backup might move to new hardware, but in your case retaining it might not do any damage, and could explain what you're seeing.

05-13-2005, 12:58 PM
I physically moved the drive from firewire to the ATA card...
Penny Stocks To Buy (http://pennystockpicks.net/)

05-13-2005, 01:31 PM
Ah. Well, then, it seems quite possible that this would be the cause, especially given the unusual setup you've got.

I'll try to do some research on this end to figure out what's up. I have no way of simulating your hardware configuration, though. If you're willing, the following test would be helpful:

- Try to Smart Update the (now-on-the) ATA drive from the original, booted from the original, and see if it continues to boot
- If not, create a new Copy Script.
- In the 'include' tab, include the "Backup - all files" script.
- Also in the 'include' tab, include the "Exclude system cache files" script.
- Save this to an appropriate name, and choose it in the main window's script pop-up
- Repeat the Smart Update and boot

Let me know if that works...

05-13-2005, 02:09 PM
I will try it later as time permits.

Do I understand correctly- you're thinking the correctly-refreshed kextcache needs to exist to startup on ATA card?

I don't understand why it can boot with refreshed kextcache, but cannot boot without it. (I could understand why it might not boot if the kextcache is wrong.)

Is the kextcache copied by SuperDuper (backup all files) or not?

(I am assuming kextcache is some kind of cache relating to kernel extensions, yes?)
XTUBE (http://www.fucktube.com/)

05-13-2005, 02:17 PM
The kextcache is copied with "Backup - all files", as is the BootCache.playlist. What I'm thinking is that, given the unusual configuration, these two caches are somehow preventing your boot when using a non-native ATA controller (when they were generated on a drive that has it onboard).

It's just a guess, as I'm not a kernel engineer and can't step you through the entire boot process, but given that they have to do with startup I thought it was worth a try.

(The kextcache is a kernel extension cache, and the BootCache helps with rapid startup.)

05-13-2005, 02:26 PM
Seems to be a likely explanation, thanks!

Apparently, starting up on ATA is prevented by the bad caches, and starting up on firewire somehow overcomes problem with the bad caches.

Next test (when time allows)- I'd like to see if it will start on ATA without the caches...
FREE WORDPRESS THEMES (http://themesfree.org)

05-13-2005, 02:44 PM
That's what I'm thinking. You can, of course, delete the files by hand after doing the copy, but for anyone who might be following along, I thought it best to include the "easy way".

05-16-2005, 12:58 PM
Tried again, deleted cache files, but drive won't startup.

(However, this test might be flawed. Intechusa.com has a solution and created a driver for high-capacity drives. They document that the startup volume must still be completely contained within the first 128GB of the startup drive. The Intech driver was never used, though. The first time I encountered the problems here and solved it by the firewire trick, the startup was within the first 128Gb. On this test, however, it was in the last 128GB. But, this drive was also connected to ATA card that supports 128GB+ drives. Also, I have not tried starting this drive on firewire yet.)

These are files that were deleted:

Are these the correct files to delete (yes?)?

Any other ideas why starting up on Firewire blesses the drive so it will subsequently startup on the ATA card?

I think my next test is to try this again, but put the startup volume in the first 128GB of the hard drive. But, any other ideas I might try now more quickly?

Ultimately, I require a solution so that this will work flawlessly without requiring use of the firewire trick...
Chevrolet 150 (http://www.chevy-wiki.com/wiki/Chevrolet_150)

05-16-2005, 01:15 PM
Well, no -- the files you want to delete are:


What I'd suggest, rather than manually deleting the files, is to create a new Copy Script. Include "Backup - all files" and, following that, also include "Exclude system cache files".

05-16-2005, 01:40 PM

Those files did not exist... :(

(BTW, I looked at a working startup, and it had BootCache.playlist but not NetworkingInterfaces.xml)
Suzuki katana (http://www.cyclechaos.com/wiki/Suzuki_Katana)

05-16-2005, 02:00 PM
That's unfortunate: it was worth a try, though.

I'm not sure what to suggest at this point, Steve. This seems to be a peculiarity of your particular hardware combination: perhaps they'll have a suggestion as to what might prevent boot...