Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Major Tiger Bug (in Tiger itself) - be aware! (

dnanian 05-05-2005 09:17 PM

Major Tiger Bug (in Tiger itself) - be aware!
I've just posted a new FAQ about a major bug in Tiger's image handling. Please read, and proceed with caution, no matter what program you're using!

Note that this applies to Tiger 10.4. Apple has fixed the bug -- and we've confirmed the fix here -- in 10.4.1. So, as long as you update to that, you should be fine.

ptaylor 05-05-2005 10:05 PM

Ah - I think that I ran into this problem (remember the image size being that odd value, when it should have been much more), but deleted and recreate the sparse disk image and I think it's been working fine since... In working on my mount/unmount scripts today, my sparse disk image has been mounted and unmounted numerous times, though, and it's still showing up as a bit over 15 GB.

I've actually just done a backup to a sparse image minutes ago (testing my scripts)... It's still showing up as expected, 15+ GB.


dnanian 05-05-2005 10:06 PM

That's lucky, Paul, but I wouldn't count on it. I didn't test all sizes. But this has bit 3 people that I'm aware of, and I was finally able to repro it consistently today.

ptaylor 05-05-2005 10:18 PM

Well, as you can tell by my other post, I'm not counting only on that sparse disk image for my backups...

Like I said, that unusual size has hit me once before... I didn't know what had happened, but it wouldn't let me mount the image, so I deleted the image and added it back, and all was well again...

I'm guessing that you've already submitted a bug report to Apple.. If so, they'll get it squared away quickly, I imagine...


dnanian 05-05-2005 11:28 PM

Yep, it's been reported...

darelon 05-07-2005 01:07 PM


Originally Posted by dnanian
I was finally able to repro it consistently today.

Could you perhaps decribe how exactly, when you have an idle moment (if any)? Because I have not been able to reproduce it at all on my clean install of Tiger, following the description in your FAQ entry.

I was a bit worried, as this bug would also seem to have the potential to interfere with FileVault. No problems encountered there yet either, fortunately.

So far SD! backups run beautifully on Tiger here. Nevertheless, the warning is much appreciated!


dnanian 05-07-2005 03:43 PM

Sure. Create a 40GB image with Disk Utility. Back up about 13GB or so of stuff to it. Unmount it. The size in Finder will be about 13GB or so. Double-click it to re-mount. The image will shrink to 1008MB and will indicate there are no mountable file systems.

darelon 05-07-2005 08:53 PM

OK, thanks, Dave. That works. I had only tried it with smaller sizes.

camaso 05-17-2005 05:19 AM

10.4.1 to the rescue?
I just ran into this bug, ironically when trying to smartupdate before updating OSX to 10.4.1
Has anyone tested, whether this bug was corrected in 10.4.1?


dnanian 05-17-2005 09:32 AM

Yes. The bug is fixed in 10.4.1. I'll update the FAQ and post.

All times are GMT -4. The time now is 07:27 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.