Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   OS X Server clone and password issues (https://www.shirt-pocket.com/forums/showthread.php?t=2377)

@msterdamned 05-09-2007 12:44 AM

OS X Server clone and password issues
 
Hi, I am trying to work out the best way to create disk images of my servers.

So I have created non compressed Read Only disk image of my main Open Directory Master server to a remote volume. I copied the disk image to a Firewire drive.

I then booted a different tower G4 from an OS X 10.4 DVD, connected th FW drive with the disc image, opened Disk Utility and restored the saved disk image to the new machine. This all went smoothly. Once the restore was finished, I rebooted the test clone server from its internal hard drive and it all started up fine. I left this new cloned machine off of the network as I did not want it to conflict with my OD master which was still up and running.

However the test clone does not recognise my admin password. Did I miss a step or do I need to do something differently. I'm guessing the problem was likely caused by Open Directory.

@msterdamned 05-09-2007 01:06 AM

Stranger and stranger
 
Weird. I can log into the machine at startup using the admin password, however once I hit the desktop and want to make any changes (IE in system preferences) the same password doesn't work anymore but my root password does.

Could this be a permissions problem, some settings I had wrong when making the disk image?

dnanian 05-09-2007 07:13 AM

That's really weird. It's possible that the OD data wasn't fully flushed to disk when we copied it: have you tried copying that server when it was offline?

@msterdamned 05-09-2007 07:22 PM

Thanks for the reply. I haven't tried taking the machine off-line before imaging, its our main file-server and it gets hit from 8am till 8pm everyday (even weekends!) which makes it hard to take down for any length of time. I was hoping SuperDuper's ability to clone the booted HD would help me avoid lengthy downtime while I create Disk Images of all my servers.

Like I said the cloned machine seems to be 100% fine apart from the Admin account issue. Could it be a permissions error of some kind?

dnanian 05-09-2007 09:14 PM

I don't think so; permissions would be copied. I think the files are all OK.

Is there perhaps a way that Apple recommends backing up the Active Directory? If so, you could run that before the backup (even automated with our before script) and then restore it...


All times are GMT -4. The time now is 08:38 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.