Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   Destination sparse image greyed out? (https://www.shirt-pocket.com/forums/showthread.php?t=5455)

Breeze 07-16-2009 01:17 PM

Destination sparse image greyed out?
 
I created a new sparse image with SuperDuper 4 days ago and I used it once already to restore my system so I know it's good. Since then I decided to create a Sandbox on another partition of my backup drive and used the "Shared users and applications" script to create it. It booted without issues.

Today I backed up to the Sandbox and that worked fine (and quick!). I also decided to update my sparse image, but now the image I created is greyed out in the "to" box and if I navigate to the image, it's greyed out in finder and I can't select it. I've checked permissions and it all seems fine. I can no longer select it in Disk Utility as a recovery source either.

I'd rather update the sparse image than spend another couple of hours creating a new image. I'd really like to understand what changed. Thanks for any help.

dnanian 07-16-2009 01:27 PM

You can select it even though it's grey....

Breeze 07-16-2009 02:11 PM

Quote:

Originally Posted by dnanian (Post 25655)
You can select it even though it's grey....

Um, no. I can't.

- In the "to" drop down the image name appears and can't be selected.

- If I chose "Disk Image..." from that drop down, I see the sparseimage greyed out in Finder and it can't be selected. It appears to darken when I click and hold over the name, but that's it. Clicking on "Save" in that dialog creates an image name in the SD drop-down, incremented with " 1". The original one is still there and greyed out.

dnanian 07-16-2009 02:23 PM

I've just tried this and can select it without trouble. Is it mounted? If so, eject it.

Breeze 07-16-2009 02:31 PM

No, it wasn't mounted. I decided to mount it to see if it was ok and it took a minute or so to validate, but then opened just fine. So I unmounted it and tried SD again with the same result.

dnanian 07-16-2009 02:35 PM

OK. Eject it and quit SD. Then, remove the "Saved Settings" folder in Library/Application Support/SuperDuper! off your Home folder. Then, restart SD! and try again.

Breeze 07-16-2009 03:27 PM

Quote:

Originally Posted by dnanian (Post 25659)
OK. Eject it and quit SD. Then, remove the "Saved Settings" folder in Library/Application Support/SuperDuper! off your Home folder. Then, restart SD! and try again.

After doing this, the sparse image still can't be selected and is still greyed out. But now SD eliminates the Smart Backup option which means that backing up will now start with the erasing of the archive and a rebuild.

I might as well just erase the old backup and start again. My Sandbox is working fine and I don't want to rebuild that too.

Is this ok or does it make more sense to rebuild both backups?

dnanian 07-16-2009 03:35 PM

Eliminates?

The image (in the destination pop-up's "Disk Image..." panel) should be selectable even though it's greyed out. I've done this (as have many others) many times, including just a few minutes ago. It'll warn about overwrite if you do this and save, but it'll select it and work.

You should then be able to choose Smart Update in Options. It's just reset to the defaults - it hasn't eliminated it.

Breeze 07-17-2009 12:11 AM

OK! I gave all this a rest... when I returned I got rid of the "Saved Settings" again as you suggested, started SD and then selected the unselectable image. And you were right, I had to select the "Smart Update..." in the "During copy" options and it worked. The default threw me.

The backup seems fine and I mounted the image to make sure. In SD the "to" listing still has the greyed out "backup" and the new "backup 1". So it works but it's a little strange.

Anyway thanks for the really great support and the quick replies! It's really appreciated :)

dnanian 07-17-2009 05:51 AM

Glad you got it to work!


All times are GMT -4. The time now is 04:11 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.