Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD would not quit (

phh 10-23-2007 01:40 PM

SD would not quit
I have scheduled an automatic back-up of one of my computers on a portable USB device, every two days. When the first scheduled back-up occurred yesterday, the external device had to be connected upon request. Although the back-up seemed to be successful, the only way I managed to quit SD was to "force quit".

How may I avoid this?

dnanian 10-23-2007 01:55 PM

Try pressing Cmd+s to save the (changed) settings, then quit.

phh 10-27-2007 07:49 AM

Thx for the advice, it works fine now. But why do we need to do this rather non-intuitive command?

dnanian 10-27-2007 09:18 AM

The bug is that SD! is in a "no user interaction" condition (because of the schedule). So, it's set up to not prompt. But, rather than quitting, you changed something (the drive), which modified the settings. When you tried to quit, it wanted to put up a panel that said "hey, the settings have changed, do you want to save them?" But it can't, because it's set up to not interact...

MacMarc 11-09-2007 12:32 PM

Happened to Me Too
I just want to add that this happened to me too, and it motivated me to come to this site to find out how to fix it.

It would be great if there were a more elegant solution to this scenario -- like a warning box or letting SD quit.


dnanian 11-09-2007 01:21 PM

I agree, Marc: this isn't something I like. But it's something we haven't yet had time to focus on (it's lower priority than a number of other things).

Ronald 12-29-2007 05:00 AM

I think the problem is a little bit different. The workaround with "save" doesn't work if the backup volume is unmounted.

benschon 01-24-2008 01:28 AM

Yes, this is a problem
Very difficult to communicate to my wife or mother that my "completely behind the scenes" back up program is the reason the computer doesn't respond to the Shut Down command at the end of a day. I have tried to instruct them that they have to Save from SuperDuper first, ("Save what? I haven't changed anything." they quite reasonably ask.) but it's frustrating that there is not at least a dialog box that walks us through this.

Isn't there an elegant way to fix this? It's a big glitch in an otherwise terrific program.

MacMarc 02-08-2008 12:27 PM

This happened again to me today -- enough time since the last time that I needed to come here to find the problem.

This is VERY annoying. My word processor prompts me to save before quitting. Why can't SD????

dnanian 02-08-2008 03:55 PM

Because there's a bug.

Cintra 02-13-2008 12:09 AM

First seen with 10.5.2

Originally Posted by dnanian (Post 14802)
Try pressing Cmd+s to save the (changed) settings, then quit.


I hadn't had this problem until I updated to 10.5.2. The Cmd+s allows me to quit ok, but I thought you might like to know.. I don't use scheduling.


dnanian 02-13-2008 08:30 AM

That's strange. Try deleting the "Saved Settings" folder in Library/Application Support/SuperDuper!, Cintra.

Cintra 02-13-2008 10:07 AM


Originally Posted by dnanian (Post 17494)
That's strange. Try deleting the "Saved Settings" folder in Library/Application Support/SuperDuper!, Cintra.

Thanks for replying dnanian

I did that, set things up again and its quitting ok now, but it did quit ok when I used the ctrl+s tip too.


Brad 02-23-2008 01:27 AM

SD! not quitting on me either in 10.5.1
Hi Dave,

I just emailed you a support ticket at Fogbugz (before searching here--sorry). I just had this happen on Susie's MacBook.

I thought I'd tried Save, but I guess I didn't, it worked just now and allowed me to quit normally. But wouldn't for several frustrating minutes. I even re-ran the SmartUpdate (another 9 min), after setting SD to quit automatically after finishing, but that didn't do it either...

Love to see a fix to this, but realize it's a workaroundable situation and that you've been busy just getting the new Leopard version out. Hope all is well.

~ Brad

edblanton 02-24-2008 01:14 PM

SD failed to quit - my solution
Was having the same problems - manual backups, apparently correct, but SD would not quit and forced a hard shutdown - all this since 10.2 and SD automatic update. Today, I uninstalled SD, downloaded the new SD 2.5 file and re-installed from that.

Problem solved, so far. SD quit and then re-booted from the backup without a problem. Hope this helps

All times are GMT -4. The time now is 02:43 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.