Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   password authentication (

Dan Lester 07-26-2021 10:34 AM

password authentication
1 Attachment(s)
Pardon all my questions, but migration to Big Sur is proceeding a bit haltingly. Your 3.5-beta3 seems to be working very well, but I have a question about copying without password authentication.

On the setup panel, one sees a lock with the words "Click to allow copying without password authentication." See screen shot below. Yes, I want to do overnight backups, so I sure don't want to have to authenticate in the middle of the night. I've responded to that, and still, somehow, I wake up in the morning to find SuperDuper asking me to authenticate the backup as an administrator before it starts doing it.

But what is funny is that you don't really know if you've allowed copying without password authentication. Is that true if the lock is open, or is it true if the lock is closed? How do I know that I have, in fact, allowed copying without password authentication? Would be nice to make that more self-evident.

In my previous implementation, it just always worked. I never had to worry about it.

dnanian 07-26-2021 11:52 AM

Is your account an admin account? Unfortunately, Big Sur requires Admin permissions for more items that you'd expect, even if being called from an app running suid 'root'...

Dan Lester 07-26-2021 03:58 PM

I have not given my account Admin privileges, but I guess I could.

Not sure what you're saying. In order to schedule an unsupervised backup without password authentication, I have to have Admin privileges?

If that's the case, what's the lock for, and why should I bother to click it?

dnanian 07-26-2021 04:04 PM

The lock does have to be clicked. That authorizes our agent to copy without admin privileges (or, rather, gives the agent admin privileges).

However, we've seen some prompting under Big Sur - typically Disk Utility/diskutil - that doesn't work if the screen is locked when the user isn't an admin.

Dan Lester 07-26-2021 11:22 PM

OK, thank you. So I want the lock clicked shut to (hopefully) allow unsupervised backups. But I too have been seeing that unexpected prompting with Big Sur. If I keep having problems, I guess I'll just have to give myself Admin privileges. I assume that will do the trick. Not a big deal.

Dan Lester 07-27-2021 11:59 AM

Well, it worked fine last night, so maybe it just does that unexpected prompting occasionally. I'll just cross my fingers.

All times are GMT -4. The time now is 11:10 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.