Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   SD Hasn't Worked for Awhile, But CCC Does. Why? (

jreffner 08-13-2013 08:23 PM

SD Hasn't Worked for Awhile, But CCC Does. Why?

With no disrespect whatsoever, I've been an SD user for many years and love it. However, for the past several months I've been getting many errors similiar to this:

| 04:04:16 PM | Error | SDCopy: Error creating symbolic link /Volumes/Mac OS Clone/System/Library/Frameworks/QuickTime.framework/Versions/Current->, error: Invalid argument
| 04:04:16 PM | Error | : Invalid argument

If I manage to fix the QuickTime, then it's just another file, after file, after file and SD can never complete.

So, out of desperation, I'm trying CCC and it is working. Do you have any idea why? I don't want to have to switch, but I'm nervous not having a cloned copy at all times. If you have any thoughts, I'd love to hear them.

Thank you so much for your time and help!

Jim Reffner

dnanian 08-13-2013 09:49 PM

Well, Jim, the directory is damaged. If you look at that particular symlink on the source, you'll see it's broken and not pointing at anything (due to the damage), and thus can't be recreated. If you look, is that the case?

jreffner 08-15-2013 02:54 PM

Ok, How do I Fix It?

Thanks for the response. I apologize for being dumb, but I can't tell. If the directory is damaged, are you referring to the "Current" directory which is mentioned as the last folder in the error?

Also, what needs to be done to fix it?

I've tried reinstalling the latest Mountain Lion Combo Update and that didn't help.

I've run Disk Warrior, Cocktail, Disk Utilities, Drive Genius, etc. all to no avail.

Could I wipe the drive (source), and then use Apple's Transfer Utility to transfer the data back from the CCC made clone to the main drive? I realize just a straight clone from the destination (Clone) back to the source (internal) would just copy my problems back again.

If you have a better idea (aside from reinstalling it all from scratch), I'd love to hear it.

Finally, I realize it is probably an impossible question to answer, but would you have any idea how this may have occurred in the first place?

Many thanks,

Jim Reffner

dnanian 08-15-2013 02:57 PM

Yes, the current symlink. If you look at it, is it a symlink/alias to nowhere?

I would try simply reinstalling Mountain Lion itself from the App Store. That should lay down a fresh, updated OS under your existing applications and data. It's painless, actually, save for the time it takes (which isn't excessive). DO NOT restore, since the backup is likely not completely valid given the damage.

It happened because of directory damage on the source. That could be because of crashes, bad shutdowns, bugs in OS's very hard to say.

jreffner 08-19-2013 08:34 AM

Thank you!
That fixed it! I can't thank you enough! FYI, a few third party apps had to be reinstalled too, but after about four of them all is fine agai.

I wasn't aware you can go back and install the entire OS over the latest version (damaged or not).

Again, thanks for the help, and for the wonderful cloning app!


dnanian 08-19-2013 08:37 AM

I'm surprised you had to reinstall applications - that's not typical. But I'm glad you're all set - we're a pretty good "detector" of bad file systems, drives, etc.

That can be frustrating, of course, if you're used to something that doesn't really let you know that you're having problems, like Time Machine.

But I think it's better to get on top of the problem ASAP, thus we jump up and down and scream until you pay attention. :)

All times are GMT -4. The time now is 06:56 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.