Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   sparseimage mounting problem - resource unavailable (

jefferyn 08-17-2010 08:28 PM

sparseimage mounting problem - resource unavailable

this error message started recently & i don't recall what might be causing it.

i back-up to a sparseimage file on one of our unix servers. for a years, i'd just run it manually. but a few weeks ago, i decided to try the backup as a scheduled back up during the night. it worked fine for a week, but then i've been seeing error message that it hasn't been successful when i come in the morning for a week now.

when i try running the backup manually, the mac mounts the nfs server, but it fails to mount the diskimage file located on the server. when i attempt to mount it from the finder, the finder displays an error message: "disk images couldn't be opened... {filename}.sparseimage - Resource temporarily unavailable. " {filename} is the real file name.

it seems to me that i've seen this before, but don't remember what it is. i searched both the apple discussion forums and also the superduper forums. but the search did not find any matches...

any idea what this problems is?

any idea how to fix it?

i appreciate any suggestions-

jefferyn 08-17-2010 08:38 PM

ps: i'd unmounted and remounted the nfs server, restarted superduper a number of times... they don't help-

dnanian 08-17-2010 08:46 PM

Have you tried restarting the NFS server? I realize that seems excessive, but it sounds like there's a lock somewhere that isn't released.

jefferyn 08-23-2010 02:07 PM

haven't been able to reboot the server. it is remote and the SA is fairly unresponsive. so i may have to try something else. though i'm not sure what the something else might be...

if that didn't fix the problem, what's my next step? possibly delete everything and start over? or is there something less severe? is there a utility or something that might diagnose a disk image problem?

thanks for the suggestion though-

dnanian 08-23-2010 02:52 PM

Well... have you tried renaming the image? I really don't know what might cause this other than a stuck lock on the server side (and we don't lock things explicitly, so it may be an NFS implementation problem with OSX or the stack on server side).

All times are GMT -4. The time now is 01:54 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.