Shirt Pocket Discussions

Shirt Pocket Discussions (https://www.shirt-pocket.com/forums/index.php)
-   General (https://www.shirt-pocket.com/forums/forumdisplay.php?f=6)
-   -   "When you connect" greyed out... (https://www.shirt-pocket.com/forums/showthread.php?t=6973)

chatoyer 10-27-2015 11:45 PM

"When you connect" greyed out...
 
If I have a USB external drive connected to my 13" MBP, the option for "When you connect <DRIVE NAME> to your Macintosh is greyed out.

Tried with two different external drives. Neither lets me schedule "when connected".

Running Version 96 on 10.11.1

Thanks in advance for any insights...

David

dnanian 10-28-2015 07:19 AM

Are you backing up to an image on that drive, or directly to the drive?

chatoyer 10-28-2015 07:24 AM

Morning Dave - backing up straight to the drive. I can manually invoke the backup, no problem.

dnanian 10-28-2015 08:08 AM

I have no idea why the option would be disabled. The only items that are disabled are images and drives that aren't returned as "ejectable" by the OS. I've got a number of USB drives here and I can turn the option on for all of them...?

chatoyer 10-28-2015 11:43 AM

Interestingly enough, when I plug in either of the two USB drives I have here on my desk, I do not get the little triangle icon in my Finder to allow me to eject. I can right click on the drive and select Eject, and it will eject, but no triangle.

Both drives work fine otherwise...

Hmm....I'm wondering if I may have some corruption somewhere.

dnanian 10-28-2015 11:54 AM

Clearly something weird is going on. But that's why "on connect" is disabled - we only enable on connect for a drive the system says is "removable", basically.

chatoyer 10-28-2015 12:03 PM

Tried reformatting one of the drives and trashing the finder plist file. Earlier, did a re-installed if 10.11.1.

No go.

Ah well. Will do a bit more research.

Thanks Dave :)

dnanian 10-28-2015 12:13 PM

It's rather weird that it wouldn't be ejectable. I wish I could offer some specific advice there! Are you an admin on the system?

chatoyer 10-28-2015 01:09 PM

I am an admin, yep. Thanks for the thought. It's definitely a system-wide issue, and if worse comes to worse, and it truly starts to drive me crazy, I'll just resort to a nuke and pave.

dnanian 10-28-2015 01:34 PM

Let's hope that's not necessary. Do you have another Mac that you've checked the drive with?

chatoyer 10-28-2015 02:30 PM

I do and I did check - all well with the drive. Eject icon/triangle appears in Finder.

dnanian 10-28-2015 02:59 PM

OK. So, at least you know it's not the drive doing something wacky.

chatoyer 10-28-2015 03:10 PM

Yep - exactly. On the problematic Mac, am noticing that external drives are slow to eject, so there is a process somewhere that is corrupted.

Minor problems like these can actually be a bit fun - your machine isn't exactly melting down, and it's an opportunity learn a bit more. (He said, before giving up and re-installing everything...)

:)

dnanian 10-28-2015 03:18 PM

A simple OS reinstall (vs. a nuke-and-pave) is likely the first step here.

chatoyer 11-01-2015 03:04 PM

A bit red faced, but it turns out that if I plug one of the drives directly into one of my MBP's USB ports, everything is fine (including the presence of eject buttons and the availability of the "When you connect" option in SD!).

The problem is only fully replicable if I plug a drive into my D-Link 7-port powered USB hub, and subsequently the hub into my MBP.

I know this set up of launching SD! when one of these same drives was connected via the D-Link had actually worked before, but I cannot be sure when it stopped working. My guess is the install of El Cap but, again, I'm not sure.

Anyway, thought I better post back with the final solution in case anyone encounters this going forward.

Thanks again, Dave.

:o


All times are GMT -4. The time now is 06:29 PM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.