Shirt Pocket Discussions

Shirt Pocket Discussions (
-   General (
-   -   Recent Leopard Updates seem to kill automount (

Van Helsing 02-17-2008 12:44 PM

Recent Leopard Updates seem to kill automount

My scheduled backup for my computer started as normal today, except to when it came to mounting the sparseimage.

Usually it connects to the Network Sharepoint and successfully mounts the image, all without a hitch.

Except today, it said that there was an error.

Indeed there was, as it had not connected to and mounted the sharepoint, thus it could not locate the sparseimage.

These issues seem to have only arisen after installing the recent Leopard updates.

Any thoughts on this?


dnanian 02-17-2008 01:26 PM

We basically just ask the OS to mount the drive by resolving an alias, so if it's failing they might have broken something. I'd suggest deleting and recreating the schedule.

Van Helsing 02-17-2008 01:34 PM


Unfortunately, deleting and recreating the schedule did not solve the problem.

Is there a way to determine toe alias SD! is using?

From there I may be able to see if whether the path SD! is trying to access is correct or not.


A restart of the computer, a final dumping of all schedules, a weird error message that wouldn't go away saying a schedule couldn't be found (which made me restart), a re-loading of my saved backup script and re-making of the schedule, and it seems to be working OK.

It's mounting the drive (I can tell this because it hasn't said it's failed yet, and also because my inbound network traffic is around 10MB/s)

*a few minutes later*

Yep. It's now copying my files, although it says I have an effective copy speed of 1,249MB/s. o.O

I know Gigabit Ethernet is fast, but really? lol

dnanian 02-17-2008 02:24 PM

The old "restart-cures-all-ills" solution! :)

Van Helsing 02-17-2008 02:28 PM

I've always hated restarting, but I have to say it does work on most occasions ;)

One thing however.

I was reading about the issues regarding prebinding, and wondered if this problem would affect me.

Because my backup is on a NAS Sharepoint, it's unlikely to be directly bootable by holding down alt on startup.

Therefore, the only way I'd find out if there were any problems would be the exact time everything does hit the fan on this computer (crosses fingers that this will never happen).

I don't want to restore from my clone, only to find that stuff crashes.

Do you have any advice? Could I run prebinding after I restore perhaps?

dnanian 02-17-2008 02:40 PM

See the thread stuck right to the top of this section.

Van Helsing 02-17-2008 03:35 PM

I've read all that - which is the reason I'm asking about it.

Should I run that shell script anyway? Even though my prebindings might be perfectly OK?

Would it harm anything?

dnanian 02-17-2008 03:42 PM

Can't hurt anything.

Van Helsing 02-17-2008 04:35 PM

I've selected it as the shell script to be executed after copy, and saved my backup script.

Van Helsing 02-17-2008 05:08 PM


Will this shell script work on Mac OS X Leopard Server?

dnanian 02-17-2008 09:28 PM

Yes, it should work fine on Server too.

All times are GMT -4. The time now is 07:21 AM.

Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2022, vBulletin Solutions, Inc.