Shirt Pocket Discussions  
    Home netTunes launchTunes SuperDuper! Buy Now Support Discussions About Shirt Pocket    

Go Back   Shirt Pocket Discussions > SuperDuper! > General

Reply
 
Thread Tools Rate Thread Display Modes
  #1  
Old 04-01-2006, 04:18 PM
cpbrooks cpbrooks is offline
Registered User
 
Join Date: Apr 2006
Posts: 5
Perform multiple backups (non-scheduled)

I have 4 scripts that I run when I perform a backup (1 for each partition I'm backing up, etc.). I'm wondering if there's a way that I can tell SuperDuper to batch run all 4 scripts without having to confirm each one (i.e., exactly as it runs when I schedule the backups). Sometimes you just want to back up everything right away and not have to wait for your regularly scheduled slot. Thanks!
Reply With Quote
  #2  
Old 04-01-2006, 04:30 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,923
Send a message via AIM to dnanian
You could do it by writing an AppleScript -- are you comfortable with that kind of thing?
__________________
--Dave Nanian
Reply With Quote
  #3  
Old 04-01-2006, 06:42 PM
cpbrooks cpbrooks is offline
Registered User
 
Join Date: Apr 2006
Posts: 5
I'm very much a beginner with AppleScript, but if I was told what to write I could get it going. But I would like to make this a feature request. I used to use Synk for backups and this kind of batch backup was what I used routinely.
Reply With Quote
  #4  
Old 04-01-2006, 06:57 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,923
Send a message via AIM to dnanian
The easiest way to do this is going to be with a little shell script, actually. Assuming you have these four jobs scheduled, here's all you have to do.

First, open the Terminal application. Then, type:

Code:
crontab -l | pbcopy
(Copy and paste that line so you get it right.)

That'll put some stuff on your clipboard. Open Text Edit with a new file, and paste.

In there, you'll see a number of lines that look something like this:

Code:
30	21	*	*	1,2,3,4,5	open file:///Users/dnanian/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20test\%20from\%20Macintosh\%20HD.sdsp/Copy\%20Job.app
These are the parts of the crontab that schedule your backup.

At the top of the file add, on a line by itself:

Code:
#!/bin/sh
Then, remove any blank lines. Edit the start of each line to remove everything up to the "open" (leaving the open and what follows it).

Finally save the result to your desktop (for now), with an appropriate name (like "BackupNow").

Then, in terminal, enter (each line on its own line, followed by Return, substituting appropriately):

Code:
cd ~/Desktop
chmod +x "the-name-of-the-file-you-entered-before"
You're done!

Now, when you double-click that file, it'll automatically queue up all of those backups and they'll run, one after the other.

Hope that helps!
__________________
--Dave Nanian
Reply With Quote
  #5  
Old 04-08-2006, 12:21 AM
cpbrooks cpbrooks is offline
Registered User
 
Join Date: Apr 2006
Posts: 5
Sorry I haven't replied yet--I've been very busy. But I will give this a shot at the next opportunity and let you know how it goes. And do think about a "batch script" that'd run like a single backup script for future releases (automating all this)--very helpful. Thanks again!
Reply With Quote
  #6  
Old 05-11-2006, 05:08 PM
cpbrooks cpbrooks is offline
Registered User
 
Join Date: Apr 2006
Posts: 5
Okay, finally got around to this, but I seem to be having a problem. I think the chmod command isn't doing it's thing. Here's what my desktop doc looks like:

Code:
#!/bin/sh
open file:///Users/cpbrooks/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20Backup\%20HOME\%20from\%20Legion.sdsp/Copy\%20Job.app
open file:///Users/cpbrooks/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20Backup\%20WORK\%20from\%20Work.sdsp/Copy\%20Job.app
open file:///Users/cpbrooks/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20Backup\%20JUDGE\%20from\%20The\%20Judge.sdsp/Copy\%20Job.app
open file:///Users/cpbrooks/Library/Application\%20Support/SuperDuper\%21/Scheduled\%20Copies/Smart\%20Update\%20work\%20Backup\%20from\%20Work.sdsp/Copy\%20Job.app
In terminal I type:

Code:
cd ~/Desktop

hit RETURN and type:

Code:
chmod +x "backupnow.txt"
I hit RETURN again and then the prompt goes to a new line, but clicking the doc just opens it in TextEdit. Any ideas?
Reply With Quote
  #7  
Old 05-11-2006, 05:32 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,923
Send a message via AIM to dnanian
Rename the file to "backupnow.sh" in Terminal with:

mv backupnow.txt backupnow.sh

That should fix it.
__________________
--Dave Nanian
Reply With Quote
  #8  
Old 05-11-2006, 07:06 PM
cpbrooks cpbrooks is offline
Registered User
 
Join Date: Apr 2006
Posts: 5
That didn't do it, but I did a search on Apple Discussions and found this info:

http://discussions.apple.com/thread....77215&#1877215

I'm don't speaky the Unix, so I don't know chmod a+x from chmod +x, but I think changing to the .command extension did the trick. Thanks for your help.
Reply With Quote
  #9  
Old 05-11-2006, 07:58 PM
dnanian's Avatar
dnanian dnanian is offline
Administrator
 
Join Date: Apr 2001
Location: Weston, MA
Posts: 14,923
Send a message via AIM to dnanian
a+x says "change user,group and owner to executable", and +x does the same thing. I'm surprised at what Finder did, but I'm glad .command worked.
__________________
--Dave Nanian
Reply With Quote
Reply


Currently Active Users Viewing This Thread: 1 (0 members and 1 guests)
 
Thread Tools
Display Modes Rate This Thread
Rate This Thread:

Posting Rules
You may not post new threads
You may not post replies
You may not post attachments
You may not edit your posts

BB code is On
Smilies are On
[IMG] code is On
HTML code is Off

Forum Jump

Similar Threads
Thread Thread Starter Forum Replies Last Post
Flaky execution of scheduled backups? No Sat. AM in "Daily"? DrDan in MA General 32 04-22-2006 05:47 PM
"Run Now" option for scheduled backups scott a General 3 03-02-2006 10:47 AM
Scheduled Backups of students home folders Kathy General 3 10-06-2005 09:22 AM
Scheduled backups? pdimesch General 4 06-13-2005 09:40 AM
Automatic multiple backups mrlatte General 1 04-30-2005 05:35 PM


All times are GMT -4. The time now is 09:50 AM.


Powered by vBulletin® Version 3.8.9
Copyright ©2000 - 2024, vBulletin Solutions, Inc.